啊,刚发现十一之前忘记更新证书,旧电脑好像是无法打开我的博客……

关注

准确的说是旧的苹果电脑。macOS 10.12.1以下的版本不信任Let's Encrypt的ISRG Root X1根证书;而旧电脑(比如2010年以前的设备)无法升级更新版本的系统。

如果妳也有旧的设备不支持 Let's Encrypt 新的(9月30日之后更新的)根证书,而网站又使用了它,就可能会遇到网站打不开或者提示证书不可信之类的情况。

具体哪些就设备请看这里:
letsencrypt.org/docs/certifica

而我恰好就还有一台古早 iMac,无法升级更新的系统了,所以,自己的博客网站都没法用这台 iMac 访问。

如何解决呢?先通过下面的链接下载新的 ISRG Root X1 根证书:

letsencrypt.org/certs/isrgroot

然后打开「钥匙串访问」(keychain access)应用,把刚才下载回来的 pem 文件拖到应用里系统钥匙串那一栏里去,然后双击这个证书,选择始终信任它。

登录以加入对话
TzCafe

一个畅所欲言的网上咖啡馆,欢迎在这里交流,就像在现实中的咖啡馆里那样。